Your Basket is Empty
Sign in to see items you may have added previously.
See samples, rewards and promotions in .

Item Added to Basket

Free Shipping!

You're only $50.00 away from Free Shipping.

Post in PLAY! by SEPHORA
|

Missing Items

These “preview” items that are supposed to be in the box are never the same. They are usually switched out for a similar/likewise item that has a lower value. #1 arrived as a different (cheaper) pencil, #2 arrived as Sephora’s generic brand, #5 was not even in the box. This is starting to become the new normal for the PLAY box.  Anyone else having this problem?222E65FA-3FF3-4E2E-9C85-C443EF7DA0EF.jpegThese “preview” items that are supposed to be in the box are never the same. They are usually switched out for a similar/likewise item that has a lower value. #1 arrived as a different (cheaper) pencil, #2 arrived as Sephora’s generic brand, #5 was not even in the box. This is starting to become the new normal for the PLAY box. Anyone else having this problem?

 

Re: Missing Items

Hi @Troyal28,

 

I'm sorry about this! Can you please clarify if you are logged into the Sephora App when viewing the "Current Box" preview? If you are not logged in, it will likely show the default preview, which may not match your box exactly.

 

If you are logged in, and your preview does not match the contents of that month's box, please send me a private message and I'll be happy to take a look further. I'm really sorry for any inconvenience, and I hope this helps. Smiley Happy

 

Best regards,

Laurie

RE: Re: Missing Items

Thank you. Much appreciated
2 Replies
Conversation Stats
  • 2 replies
  • 687 views
  • 1 Hearts Given
  • 2 Contributors
Photos1
  • These “preview” items that are supposed to be in the box are never the same. They are usually switched out for a similar/likewise item that has a lower value. #1 arrived as a different (cheaper) pencil, #2 arrived as Sephora’s generic brand, #5 was not even in the box. This is starting to become the new normal for the PLAY box.  Anyone else having this problem?