mafan

Changes to the website

(0) Hearts

As I saw violalea and rikkie mention in another thread, there have been some website updates today.  I like having the stores link up at the top -- makes it easy to find a store, check out events, etc.  (Oh, was it hard knowing there was an event at Prudential and driving past without stopping last Saturday.  Definitely not on my husband's city agenda!)

 

Unfortunately, I'm now having problems with certain things using Firefox.  When I go to check out my "Loves" it just spins and spins with the Sephora "S".  I also couldn't pick out samples.  I eventually had to go over to using IE to place an order.  These things all worked fairly recently, probably yesterday, because I tend to check to see if some sale things have come back in stock.  (I only got lucky and saw on my phone that the brush I wanted was back in again.)

 

Is anyone else using Firefox and having problems?

mafan

Re: Changes to the website

(0) Hearts

clearing your cache/cookies might work -- it did for me.

 

Of course, I'm home now and IE 10 isn't letting me reply directly to a post.  No idea if it's the browser or the site.

RosieLA

Re: Changes to the website

(0) Hearts

I am having problems, too. None of the items actually show up for me on Firefox, and my Firefox is up to date. Not sure why it's like that especially since it works for some.

laurabt

Re: Changes to the website

(0) Hearts

@RosieLA- It sounds like you may need to update your plug-ins, or clear the cookies and cache on your internet browser. Hopefully that helps. :smileyhappy: -Laura

makeupmaven

Re: Changes to the website

(0) Hearts

I noticed this too on firefox re: Sephora "S" for the Beauty Bag, but once I hit the refresh button it was fine.

 

joeanne

Re: Changes to the website

(0) Hearts

I use Firefox and everything seems OK. I checked out my "loves" and tried adding samples to my bag (not that I'm really buying anything....today at least) and it worked fine. Firefox can definitely be wonky sometimes and like you I've had to use IE on a few sites, but hopefully, Sephora will keep working for me!

rikkie

Re: Changes to the website

(0) Hearts

I hope that gets resolved quickly! I haven't had any issues but I'm using chrome, which I like over Firefox most of the time because Firefox can be pretty memory intensive and that can really slow things down.

mommyto4

Re: Changes to the website

(0) Hearts

I don't have the same problem with the Loves section, but I can't add samples either.  I didn't have a problem yesterday.  Now today it is a problem.  I also use Firefox.

miabt

Re: Changes to the website

Hi mafan,

 

We haven't had any reports of problems with Firefox, but I can definitely check with our IT Dept & pass along your feedback on the update so far.  I tried it myself & Sephora.com seems to be working ok with my Firefox, however I tend to use Google Chrome, as I've found it works the best with that browser.  Try clearing the cache/cookies for your Firefox, as I need to periodically do that to optimize viewing of the site :smileyhappy:  

 

xo, Mia

Advanced
You must be signed in to add attachments
Conversation Stats
  • 8 replies
  • 227 views
  • 2 hearts
  • 8 in conversation
    • makeupmaven
    • mafan
    • joeanne
    • miabt
    • RosieLA
    • rikkie
    • mommyto4
    • laurabt