Website problems?

When clicking on the general tab names "makeup, skincare" etc, or the subdivisions within them (palettes and value sets, face, eyes) to see general categories of products, my webpage does not load, and gives me the logo at the top of the page and the rest is white. This also happens when I search a product in the search bar, and this has been going on on all different computers i've tried, and all different wifi networks i've tried. I've been reduced to knowing what I want, and searching the name of the product with "sephora" after it in a google search, which finally displays the product page for me. Anyone else having this problem? I'd like to just simply browse the "what's new" section among others on the website. I've noticed that the site has changed... maybe that can be attributed to this issue i'm having?

Re: Website problems?

(0) Hearts

It has been happening to me too.  I've cleared the cache as well.

Re: Website problems?

(0) Hearts

My Sephora website also does this, and I do the same thing with the search, it's super frustrating. I am using Firefox on a mac. It also does the same thing on safari on my computer, which I don't ever use. any fix for this?

Re: Website problems?

(0) Hearts

Hi ilovejuiceboxes,

 

If you havent already done so, I'd suggest clearing the cache for your browser to optimize the features on Sephora.com.  If the problem persists, please give us a call at 1-877-SEPHORA and we'd be happy to help Smiley Happy

 

xo, Mia

Re: Website problems?

(0) Hearts

Hi Nattygirl.  Which browser are you using?  We have had that issue reported with Safari.  Clearing your cookies/cache or trying a different browser might help.

Conversation Stats
Photos1
  • Screen Shot 2017-02-12 at 5.45.42 PM.png